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Important Notice
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The following are copyrights of their respective companies or
organizations:

Adobe Type Manager © 1994 Adobe Systems, Inc. All rights
reserved.

Display PostScript © 1994 Adobe Systems, Inc. All rights reserved.

ImageStream Graphics Filters © 1991-1993 ImageMar1< Software
Labs, Inc. All rights reserved.

Milo © 1988-1991 Ron Avitzur

PANTON~ Computer Video simulation used in Frame Software
may not match PANTON E-identified solid color standards. Use
current PANTONE Color Reference Manuals for accurate color.
PANTONE Color Computer Graphics © Pantone, Inc. 1986, 1988.

The spelling and thesaurus portions of Frame Software are based on
THE PROXIMITY LINGUISTIC SYSTEM © 1992 Proximity
Technology Inc.; C.A. Stromberg AB; Espasa-Calpe; Hachelle; IDEI
AS; Kruger, L1uis de Yzaguirre i Maura; Merriam-Webster Inc.;
Munksgaard Int. Publishers Ltd.; Nathan; Text & Satz Datentechnik
Van Dale Lexicographie bv; William Collins Sons & Co. Ltd.;
Zanichelli. All rights reserved.

The installer software used by the Windows version of Frame
Software is based on the Microsoft Setup Toolkit © 1992 Microsoft
Corporation.

TypeScaler © 1989 Sun Microsystems, Inc. All rights reserved.

The following are trademar1<s or registered trademarks of their
respective companies or organizations:

Adobe, Adobe Type Manager, ATM, PostScript, SuperATM,
Adobe Printer Driver / Adobe Systems Inc.

Apple, AppleLink, AppleScript, AppleTalk, Balloon Help, Finder,
ImageWriter, LaserWriter, PowerBook, QuickDraw, QuickTIme,
TrueType, XTND System and Filters; Macintosh and Power
Macintosh, used under license / Apple Computer, Inc.

ImageStream Graphics Filters /lmageMark Software Labs, Inc.

Milo / Ron Avitzur

Proximity, Linguibase / Proximity Technology Inc.

Sun Microsystems, Sun Wor1<station, TOPS, NeWS, NeWSprint,
OpenWindows, TypeScaler, SunView, SunOS, NFS, Sun-3, Sun-4,
Sun386i, SPARC, SPARCstation / Sun Microsystems, Inc.

All other brand or product names are trademar1<s or registered
trademar1<s of their respective companies or organizations.

Any provision of Frame Software to the US Government is with
"Restricted Rights" as follows: Use, duplication, or disclosure by the
Government is subject to restrictions set forth in subparagraphs (a)
through (d) of the Commercial Computer-Restricted Rights clause at
FAR 52.227-19 when applicable, or in subparagraph (cH1 Hill of the
Rights in Technical Data and Computer Software clause at DFARS
252.227-7013, and in similar clauses in the NASA FAR Supplement.
Any provision of Frame Software documentation to the US
Government is with Limited Rights. The contractor/manufacturer is
Frame Technology Corporation, 333 West San Carlos Street,
San Jose, CA 95110.

US versions and some international versions are printed in the
United States.

Frame Technology~Corporation ("Frame") and its licensors retain all
ownership rights to the FrameMake~computer program and other
computer programs offered by Frame~ (hereinafter collectively
called "Frame Software") and their documentation. Use of Frame
Software is governed by the license agreement accompanying your
original media. The Frame Software source code is a confidential
trade secret of Frame. You may not allemptto decipher, decompile,
develop, or otherwise reverse engineer Frame Software, or
knowingly allow others to do so. Information necessary to achieve
the interoperability of the Frame Software with other programs may
be available from Frame upon request. You may not develop
passwords or codes or otherwise enable the Save feature of Frame
Software. Frame Software and its documentation may not be
sublicensed and may not be transferred without the prior wrillen
consent of Frame.

Only you and your employees and consultants who have agreed to
the above restrictions may use Frame Software (with the Save
feature enabled), and only on authorized equipment.

Your right to copy Frame Software and this publication is limited by
copyright law and your end user license agreement. Making copies,
adaptations, or compilation wor1<s (except copies of Frame Software
for archival purposes or as an essential step in the utilization of the
program in conjunction with the equipment), without prior written
authorization of Frame, is prohibited by law and constitutes a
punishable violation of the law.

FRAME TECHNOLOGY CORPORATION PROVIDES THIS
PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND,
EITHER EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED
TO THE IMPLIED WARRANTIES OR CONDITIONS OF
MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. IN NO EVENT SHALL FRAME BE LIABLE FOR ANY
LOSS OF PROFITS, LOSS OF BUSINESS, LOSS OF USE OR
DATA, INTERRUPTION OF BUSINESS, OR FOR INDIRECT,
SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF
ANY KIND, EVEN IF FRAME HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES ARISING FROM ANY DEFECT
OR ERROR IN THIS PUBLICATION OR IN THE FRAME
SOFTWARE.

Frame may revise this publication from time to time without notice.
Some states or jurisdictions do not allow disclaimer of express or
implied warranties in certain transactions; therefore, this statement
may not apply to you.

Copyright © 1986-1995 Frame Technology Corporation. All rights
reserved.

In the United States, Frame, the Frame logo, Frame Technology,
FrameBuilder, FrameMaker, FrameReader, and FrameViewer are
registered trademar1<s, and the Frame stylized mark, Frame
Application Program Interface, Frame Develope(s Kit, Frame
Development Environment, FrameConnections, FrameMaker
International Dictionaries, FrameMaker+SGML, FrameMath, and
FrameServer are trademar1<s, of Frame Technology Corporation.

The following are trademar1<s or registered trademar1<s of Frame
Technology Corporation in countries outside of the United States:
Frame, Frame Application Program Interface, Frame DevEllope(s
Kit, Frame Development Environment, the Frame logo, Frame
Technology, FrameBuilder, FrameConnections, FrameMaker,
FrameMaker+SGML, FrameMaker International Dictionaries,
FrameMath, FrameReader, FrameServer, and FrameViewer.
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A First Look at New Features

With release 5, FrameMake,-@ publishing software introduces many features that add power
and versatility to the way you work. Some of the features are entirely new, such as the ability
to make paragraphs straddle columns or to have text flow smoothly around a graphic.
Others are improvements on functionality you may already be familiar with.

If you are acquainted with release 4 of FrameMaker, this manual will give you a running
start on release 5. Take a few moments to read this chapter for a look at the new features.
Then as you work with the software, tum to Chapter 2 when you have questions about
changes to specific commands or shortcuts.

(

(

In this chapter
This chapter provides an overview of the new features. It begins with FrameMaker's new
approach to laying out text columns, anchored frames, and other items on a page:

"Text frames, text columns, and side heads" on page 2

"Straddles" on page 3

"Text runarounds" on page 6

"More anchored frame positions" on page 7

Now you can use text stored in other locations and let FrameMaker do the updating:

"Text imported by reference" on page 10

"Automatic updating of references" on page 11

An enriched set of features simplifies everyday work with text, graphics, links, and files:

"Editing enhancements" on page 11

"Hypertext enhancements" on page 12

"Refinements to the interface" on page 15

"More efficient performance" on page 16

FrameMaker documents move transparently from one platform or product to another:

"Cross-platform support of documents" on page 17

"New and updated filters" on page 17

You'll find the new features covered thoroughly in Using FrameMaker:

"Where to go for more information" on page 19

What's New in FrameMaker 1



1 Text frames, text columns, and side heads Go To ......

Text frames, text columns, and side heads
(

FrameMaker uses a new, simplified model for page design that makes it easier to lay ou
text columns and side heads. The new model also makes it possible to have paragraphs,
tables, and other items straddle columns.

In earlier releases of FrameMaker, each text column was an individual object on a page.
You could draw columns one by one and connect columns to flow text through them. To set
up side heads, you had to make one of the columns wide enough to include the side-head
area and then turn on a side-head property to move all paragraphs not tagged as side
heads into the "normal" part of the column.

In FrameMaker 5, you work with text frames instead of with individual text columns. Each
text frame can hold one or more columns of equal size, plus an area for side heads. With
this approach, you can specify the basic layout characteristics of a page simply as (
properties of one text frame.

E=V=~.=·._~····=·-··="···=····-=··'i-i -H--- ~~~:~::o:;~:o~:~~

;;~:-h_e_a_d_-jL.~l_~j:::_.=:_::llll-:ll:iI-~"-~';;;;;;1;Y-- Text columns

FrameMaker handles the flow of text in text frames for you. The text in one frame flows
automatically from one column to the next one in the frame. When the entire text frame is
filled with text, FrameMaker adds a new page with another frame, and the text flows to the(
new frame.

You may sometimes need to redirect the flow in a document-for example, to start an article
on the first page of a newsletter and then continue it on a later page. In these cases, you
can change the flow manually as you could in earlier releases of FrameMaker.

Older documents If you open a multicolumn document from an earlier release of
FrameMaker, the text columns on a page are converted to a single multicolumn text frame
as long as the columns are connected from left to right, do not have a side-head area, have
the same properties (such as size and fill), have equal column gaps (if there are three or
more columns), and are not rotated.

A First Look at New Features 2
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To specify the default layout for a flow, you use the new Column Layout command
(Format>Page Layout sUbmenu). You can set page margins and the number of columns and
gap between them with this command. If you want a side-head area, you also specify width,
gap, and page side for the area.

You use the new Customize Text Frame command (Format>Customize Layout submenu) to
modify a particular text frame. You can change many characteristics of a frame, including
size, border style, flow tag, number of columns, and settings for a side-head area.

The Text Column tool on the Tools palette (Graphics menu) is now the Text Frame tool.
When you click the tool and drag, you now draw a text frame rather than a column. A dialog
box appears automatically so that you can specify the number of columns in the new frame
and the gap between them.

Many other page layout features in FrameMaker have the same functionality as before but
are organized differently in the interface to be easier to work with. For a summary of the
changes, see "Format menu" on page 24.

Straddles
A paragraph, footnote, table, or anchored frame can now straddle two or more columns on
a page. The straddle spans the full width of all the columns in the text frame, or the width
of the columns plus the side-head area.

You can use a straddle in any text frame that has two or more columns. The text in the
frame flows through the columns above the straddle, then through the straddle itself if it is
a paragraph, and finally through the columns below the straddle.

~~
CO; How Coffee Is Harvested") --iil--- A straddle, like this heading,

C ill - :::":~",~~ I~~d~d~_h'"
area. The flow of text breaks
at the straddle.

L• __-"-"!PI~""",,","~ .."", ~
-~ -- ~ """

FrameMaker automatically balances the amount of text in the columns above a straddle to
give the columns an even appearance.

What's New in FrameMaker 3



1 Straddles Go To .... I
Paragraph straddles
Any type of paragraph can straddle columns on a page, but straddling is especially usefu
for heading paragraphs. For example, in a two-column layout you may want a heading to
straddle columns so that it distinctly marks the beginning of a new section. You can make
a paragraph straddle only the columns or both the columns and the side-head area.

F.====:----..=-====1

==- I A paragraph can straddle
Fiber Optics -+,-H-- only the columns ...

...or both the columns
and the side-head area.

i················==··········==!
'----- ---,. ----,

~ I
[Fiber Optics !

-----,. ==== ==-1
j ===- ====1-----_. (

To make a paragraph straddle columns, you use the Pagination properties of the Paragraph
Designer (Format>Paragraphs submenu).

Footnote straddles
A footnote can also straddle columns. You specify the straddle in the Pagination properties
of the Paragraph Designer, as you do with other types of paragraphs. Most often, you'll want
the footnote to straddle only the columns and not the side-head area.

E
--=--==

_ 1
-- ---------------

t
Fiber Optics_

--------------- -----------------
--_.~--....

A footnote can
straddle columns, just
as paragraphs can.

(

Footnote straddles always appear at the bottom of their text frame, even if the footnote
reference is above another straddle item (such as a heading) in the frame.

A First Look at New Features 4
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(
Table straddles
When a table straddles columns, you do not turn on the straddle properties yourself.
FrameMaker determines whether the table will straddle columns.

A table automatically straddles all columns when the table is wider than a single column
plus the column gap. In a text frame with a side-head area, a table wider than the column
area plus the side-head gap also straddles the side heads.

.-'- ==== ====i

~====:

--'

----,----,

--------,----1

==== ===-.,

=== I:
I I I I i

A table straddles
columns if it is wider=== I than one column plus ,

EIE131~1~lltir-gap... II
...or straddles columns ---lY
and side heads if it is
wider than the column
area plus side-head gap.

(

If a table is anchored in a paragraph that is a straddle, the table is also a straddle and it
spans at least the same width as the paragraph. In this case, the table is always a
straddle-even when it is not wider than a single column plus gap.

I
----j

i
i----,

1 ==- ====:......----!. ----,---:==------':1r--=== =-
-~~~~~-~~~r.~~- If a table is anchored inI i- a paragraph straddle, the
I I I I I :1 table is also a straddle.

I
The table straddles even -+-1...../

r--'-- -- when it is not wider than ...... =-_==-_= ==-:
======== =======-1 one column plus gap. - :

..............= ....=.1 '.. ==J

(

Anchored frame straddles
Like tables, anchored frames can straddle columns automatically. For an anchored frame to
straddle, it must be positioned inside a text column (rather than outside a column or text
frame). The way the anchored frame straddles depends on whether or not the frame is
cropped.

(
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1 Text runarounds Go To ....... I
If an anchored frame is uncropped, it straddles columns in all the same ways that a table
straddles them. (

If an anchored frame is cropped, it straddles columns only if the frame is anchored in a
paragraph that is a straddle. The behavior is the same as a table anchored in a paragraph
straddle except that a cropped frame always straddles the same width as the paragraph. If
the frame is wider than the paragraph's straddle width, the frame is cropped to fit the space.

r-~~~-'--'_:_==;-I :t,~~~~:~:;'~,:" width r==~1
11--- __I~+--f+-- :;.~;~;;;:;;;~:~~;.~: [I ) < I
I ,I-- The frame is cropped to i === ====-!
! ---- fit the new width. i === === !
i ---- ; ----;

(

Text runarounds
You can now make text in a FrameMaker document "run around" a graphic on a page. The
graphic is attached to a fixed location on a page, and the text flows around the graphic. This
lets you design visually striking layouts, with text and graphics side by side.

You can run text around many types of graphics this way-for example, rectangles, ellipses,
polygons, arcs, unanchored frames, and imported graphics. The border of the text can follow
the contours of the graphic or of a rectangular boundary around the graphic.

A text runaround can
follow the contours of
a graphic ...

boundary around the
graphic. --------j

(

Text can run around either side of a graphic. If you place a graphic over part of two or more
columns, the text runs around both sides of the graphic.

A First Look at New Features 6
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(

(

In a multicolumn layout such as a newsletter, you may want to use a graphic that is the full
width of a column and have text stop above the graphic and then start again below it. To
do this in earlier releases of FrameMaker, you needed to create separate columns above
and below the graphic and then connect the columns. In FrameMaker 5, you can easily lay
this out as a text runaround.

1-----------

JazzMatazz

=_==-_= =_==- "HS-- A text runaround
__ provides an easy way

i ==- j to interrupt the flow of
.• text with a graphic.

..._._ _ __ _._._.._-_._ _-_._ .

To prepare a text runaround, you draw, paste, or import a graphic directly on a page and
then use the new Runaround Properties command (Graphics menu) to assign runaround
properties to the graphic. The graphic can be anywhere on the page-FrameMaker adjusts
the text's borders automatically to accommodate it.

When FrameMaker adjusts the left border of text to accommodate a graphic, it preserves
any indentations the text already has. For example, if the first line of a paragraph is indented
one-half inch, the first line is still indented that amount when it moves over.

You can prepare a text runaround on master pages as well as on body pages. The text runs
around the graphic on all body pages that use that master page.

( More anchored frame positions
FrameMaker gives you more anchored frame positions for greater flexibility in placing
graphics on a page. You use the Anchored Frame command (Special menu) to set the
anchoring position for a frame.

Alongside a paragraph
You can now position an anchored frame alongside a paragraph and have the paragraph
indent to accommodate the frame. A run-in frame is useful for a small graphic you want to
keep with a specific paragraph or for a drop cap at the beginning of a paragraph.

(
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1 More anchored frame positions Go To ..... ~

The anchored frame can be on the right or left side of the paragraph (or on the page side
closer to or farther from the binding in a double-sided document). \

r---
I

.-....---, ---+-1
1

- ..... -------

.J.-+!-- A run-in frame can be ..J..
paragraph. The text
indents to flow around
the frame.

(,
To prepare a run-in frame, you give the frame the new anchoring position Run into
Paragraph. The frame is top-aligned with the tallest text in the first line of the paragraph,
and the text in the paragraph appears right- or left-indented to flow around the frame.

When FrameMaker adjusts the left border of text to accommodate a run-in frame, any
indentations in the paragraph (such as first-line indent) disappear if the frame is wider than
the indentations. In the figure on the right above, for example, the second paragraph has
no first-line indent because the frame is wider than the indent specified. If you want to
preserve an indentation, you make it wider than the frame.

If the anchored frame is taller than the paragraph, FrameMaker uses text from the
paragraphs that follow to continue running text alongside the frame.

The effect of a run-in frame is similar to the new text runaround feature (described on
Qillill..Q). But a run-in frame is anchored to a paragraph rather than to a fixed location on a
page. If the paragraph moves up or down in the document, the frame moves along with it.

Inside a text column
(

If you position an anchored frame inside a text column, you can align the frame with the
left, right, or center of the page, as you could in earlier releases of FrameMaker. If the
document is double-sided, now you can also align the frame with the page side closer to or
farther from the binding.

t _.L .._. ..__ ....._...
H

Side closer to the binding Side farther from the binding

A First Look at New Features 8



1 More anchored frame positions GoTo ..... I
Outside a text column
If you position an anchored frame outside a text column, you can align the frame with the
left or right side of the page, or with the side closer to or farther from the page edge, as
you could in earlier releases of FrameMaker. If the document is double-sided, now you can
also align the frame with the page side closer to or farther from the binding .

.-::-:::-:::::::..1

Side closer to the binding Side farther from the binding

Generally, you use these new alignments outside a text column only in a one-column layout.
If you want to align a frame closer to or farther from the binding in a layout with two or more
columns, you can position the anchored frame outside the text frame.

Outside a text frame
In FrameMaker 5, you can also position an anchored frame outside a text frame entirely. If
you're working with pages that have two or more columns and you want anchored frames
always to appear in the page margins, never between columns, you should position the
anchored frames outside the text frame.

The alignment options for positioning an anchored frame outside a text frame are the same
as they are for placing it outside a column: You can align the frame with the left or right side
of the page, with the side closer to or farther from the page edge, or (in a double-sided
document) with the side closer to or farther from the binding.

Side closer to the binding Side farther from the binding

r
In a one-column layout, these settings have the same effect as positioning an anchored
frame outside the column.

What's New in FrameMaker 9



1 Text imported by reference GoTo V

Text imported by reference
(

You can now import text from other documents, or from other parts of the same document~
by reference to the source location. You can import any document that can be opened in
FrameMaker-inciuding text files, other FrameMaker documents, and documents filtered
from other applications.

Text imported by reference into your document is an image of the referenced text; it is not
editable. FrameMaker maintains a link between this text inset and its source. Whenever an
inset is updated, FrameMaker reimports the text from the source so that your inset stays in
sync with the original.

Source document

A text inset maintains a
link to a source document.

(
~--------+ji Biofuels i ...1

cr;=::=:J
IAquatic Life

l_. =_.

r--··------

To import text by reference, you use the same Import File command (File menu) that you've
used for importing graphics and for copying text in earlier releases of FrameMaker. If you're
importing from a FrameMaker document or from a filtered text document, you can retain the
text's original format, reformat the text to use the catalogs in your document, or reformat it
using the paragraph format at the insertion point.

You mark a text inset for automatic or manual updating when you import it. With automatic
updating, the inset is updated whenever you open the document. (

You can manually update insets in a document with the new Update References command
(Edit menu). You can also use this command to suppress all automatic updating in the
document. If you're working with a book and don't want to update insets, use the new
Suppress Reference Updating command (Edit menu for books) to suppress automatic
updating for documents you open through the book file.

The new Text Inset Properties command (Edit menu) tells you the source of an inset and
when it was last updated. You can also use this command to update a particular inset,
convert the inset to text, open the source document, or change settings such as automatic
or manual updating.

l
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(
Automatic updating of references

When you open a document in Normal format, FrameMaker now updates cross-references,
system variables on body pages, and any text insets that are marked for automatic updating.
When you print, it also updates cross-references to open documents and system variables
on body pages.

You can suppress all automatic updating for a document with the new Update References
command (Edit menu). If you're working with a book, you can suppress automatic updating
for documents that you open from the book window with the new Suppress Reference
Updating command (Edit menu for books).

Editing enhancements
FrameMaker provides several new features that simplify common tasks for editing tables,
text lines, and graphics.

Joining lines and curves
You can now create complex outlines by joining individual lines, polylines, arcs, or smoothed
polylines that were drawn with FrameMaker drawing tools. Joining curves is an easy way to
create objects that would be cumbersome to draw all at once.

Once you've joined lines and curves, you can reshape the new object and change its pen
width, fill color, and other properties.

(\

I I
You can join individual
lines and curves ...

... into one continuous
outline.

The outline is a permanent
object that can be filled.

(

To join lines and curves, you position them to make sure their ends are touching, select the
lines and curves, and then choose the new Join command (Graphics menu). The curves
form one permanent object; you cannot "unjoin" them later.

What's New in FrameMaker 11



1 Hypertext enhancements GeTe ..... I
Quick formatting in table cells and text lines
FrameMaker can now format all text in selected table cells or text lines with "quick" (
commands in the formattinn bar, the QuickAccess bar, and the Format>Style submenu. In
earlier releases of FrameMaker, you needed to select particular text in a cell or text line
before applying these commands to it. Now you can select the cell or the text line itself­
and even multiple cells and text lines-to format all text in them.

Among the commands affected by this change are the style properties (such as Bold and
Italic) on the Format>Style submenu; the style, font size, and capitalization buttons in the
QuickAccess bar; and (for table cells but not text lines) the Alignment and Spacing pop-up
menus and Update All and New Format commands in the formatting bar.

Scaling values for imported graphics
In the UNIX and Windows versions, you can now change the dots-per-inch (dpi) scaling (
value for an imported bitmap graphic without having to reimport. To do this, you select the
graphic and use the Object Properties commahd (Graphics menu) to set a new value.

This feature was already available in the Macintosh@ version.

Hypertext enhancements
A few improvements to FrameMaker hypertext make it easier to develop sophisticated online
documents.

Variable window settings for referenced pages
When you click in an active area of a generated hypertext file (such as an index or table of
contents), you jump to the source of the reference (such as a section) in another document.
The other document is the referenced document. FrameMaker displays the appropriate
page from the referenced document in either the current window or a new window.

In earlier releases, you used the generated file to specify which window you wanted to use(
for pages from referenced documents, and the specification applied to all documents. Now
you can specify the window in each referenced document-which allows you to have
different window settings for different documents.

To specify which window you want a page to appear in when you jump to it from a generated
file, you create a flow tagged HypertextLinks on a reference page in the referenced
document. Type gotoObjectID in the flow to display the page in the generated file's
current window, or type openObj ectID to display it in a new window.

l
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A

(

Automatic thumbtabs in indexes
In an index for a hypertext document, you may want to have '~humbtabs" across the top of
the page as links to the index's group titles. You click an A thumbtab to go to the page where
the A entries begin, click a B to go to the page where the B entries begin, and so on. This
makes it easy to navigate in a large index.

ABCDEFGHIJKLMNOPQRSTUVWXYZ-lil!r-- You click a thumbtab in
an index to go to the first
page of index entries
beginning with that letter.

Now FrameMaker automates thumbtab linking. To prepare links from thumbtabs to group
titles, you add gotol ink commands to the thumbtabs and turn on Create Hypertext Links
in the Set Up File dialog box (File menu for books). When you generate the index,
FrameMaker adds newlink markers automatically at the beginning of each group title. In
earlier releases of FrameMaker, you needed to add the newlink markers manually.

Submenus for pop-up menus
A hypertext document can have a pop-up menu with links to related information. In earlier
releases of FrameMaker, each item on a menu needed to be a direct link to another topic.
Now you can put submenus on a pop-up menu for another layer of items.

[., _-_ __ _--_..

MARINE MAMMALS
Dolphins
Manatees
Seals ~

Sea Otters
Walruses
Whales

Fur
Harp
Monk

t--- A pop-up menu can
have a submenu for
another layer of linked
information,

(

When you specify the items for a pop-up menu, you list the items in a flow with a tag that
matches the flowname in the popup command, To include a submenu on a pop-up menu,
you use a second popup command in the item list and list that menu's items in another
flow. A popup menu can have one level of submenus.

What's New in FrameMaker 13
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Titles for hypertext alert boxes
You can create alert boxes that display messages in hypertext documents. In earlier (
releases of FrameMaker, the alert boxes were always titled simply FrameMaker - Alert. In
UNIX and Windows, you can now give an alert box any title you want.

~L==~u~n~a~v~aITila~b~l~e£F~ile~~~~~-- An alert box can have
a custom title.

Contact the author to view this document.

To specify a default title for all hypertext alert boxes in a document, you create a flow tagge
AlertTitle on a reference page and type the title text in the flow. To specify a title for a certain
alert box, you use the new hypertext command alerttitle title:message to define
both the title and the message for the alert. The title and message together can be up to
255 characters long.

Commands for fitting a window to a page
FrameMaker provides new hypertext commands for linking to a topic: gotolinkfitwin,
openl inkf i twin, and previousl inkfi twin.

These commands display the referenced topic just as the commands gotolink,
openlink, and previouslink do, but they also resize the window to fit the page. This is

useful when an online document is linked to another file with a different page size or
orientation.

Links and bookmarks for Adobe Acrobat
You can now use FrameMaker as an authoring tool for online documents to be displayed inC
Adobe Acrobat. After writing the documents in FrameMaker, you use the Print command
(File menu) to save them as PostScript files; a new Print option "Generate Acrobat Data"
sets the printing values appropriately for Acrobat. You then use the Adobe Acrobat Distiller
application to convert the files to the Portable Document Format (PDF). The flows you set
up in FrameMaker are converted to article threads in Acrobat, and all hypertext and cross­
reference links in the document are preserved (even links that are automatically generated).

Acrobat uses "bookmarks" to create a collapsible outline with headings that readers can
click to go to sections in an online document. To prepare the bookmarks in FrameMaker,
you use a new Acrobat Setup dialog box available with the Print command to select which
paragraph tags become bookmarks and to specify an outline level for each tag.

A First Look at New Features 14
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(

(

(

Refinements to the interface
The FrameMaker interface has been refined to give more intuitive access to the features
you need. This section describes some of the most important changes. For a more complete
summary of the changes, see Chapter 2. "Changes to the FrameMaker Interface."

Improved dialog boxes
Several of the dialog boxes in FrameMaker are easier to use:

• Paragraph Designer, Basic properties (Format>Paragraphs submenu): The Tab Stops
scroll list has a new checkbox with three states-on, off, and as is. When more than
one paragraph is selected, you can turn on the checkbox to apply the tab stops to all
of the selected paragraphs, turn off the checkbox to remove the tab stops from the
paragraphs, or set the checkbox to "as is" to leave the tab stops as they are.

• Anchored Frame (Special menu): This dialog box now lists all of the anchoring
positions on a pop-up menu. When you select a position, the rest of the dialog box
shows only the options (such as size and alignment) that are appropriate.

• Add File to Book (File menu for books): This dialog box now stays open while you add
files to a book, so it is much easier to add more than one file at a time. When you're
finished adding files, you click Done to close the dialog box.

• Marker (Special menu): In the UNIX and Windows versions, the Marker Text box is
larger so that it can display several lines of text rather than one. This makes it much
more convenient to type and edit long passages of marker text, particularly for index
markers with character format changes, range specifications, or a group of entries.
(The Marker Text box in thE! Macintosh version already displayed several lines.)

• Color pop-up menus in dialog boxes: In the Macintosh version, the Color pop-up
menus now show swatches of color next to the color names.

• New, Open, Save As, and Import File (File menu): In the Windows version, the file
dialog boxes now have a N·etwork button. If you're running Windows for Workgroups
release 3.11, you can click this button to open a dialog box for connecting to other
hard drives or partitions available on your network

Small Tools palette
The Tools palette (Graphics menu) in the UNIX version of FrameMaker is now available in
an abbreviated size as well as in its full size. The small palette takes up much less space
on your screen. You can go back and forth between the small and large Tools palettes by
clicking a toggle switch at the bottom of the palette.

The small Tools palette has all of the drawing tools and the same object properties (such
as fill pattern and pen width) thrat the large palette has; the properties are on pop-up menus
so that they use less space. The small palette does not have the Graphics menu
commands.
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The small Tools palette was already available in the Windows and Macintosh versions. The
Macintosh version also has a large Tools palette. (

QuickAccess bar
The UNIX version now has a QuickAccess bar with buttons you can click to apply
commands. The bar has buttons for many of the most commonly used commands in
FrameMaker, such as New, Save, and Print for files; Bold, Italic, and Find for text; Group,
Align, and Distribute for graphics; and Select Row, Insert Row, and Straddle for tables.

The QuickAccess bar was already available in the Windows and Macintosh versions of
FrameMaker. In all versions, the buttons are now in color on a color monitor or in grays on
a gray-scale monitor.

You use the QuickAccess Bar command (View menu) to open the bar. (

More efficient performance
In the Macintosh version of FrameMaker, two new features help you work more efficiently.

Support for AppleScript
The Macintosh version now supports AppleScript, a high-level programming language
available on Macintosh computers running System 7 or later. With a syntax of command
verbs and object nouns that is patterned after human language, AppleScript provides an
easy way to write scripts that simplify your work.

You can use AppleScript to customize document properties in FrameMaker and to automate
tasks that would otherwise be repetitive or time-consuming. For example, you might write a
script to automate the updating of generated files and cross-references in a book; to turn
off borders and text symbols in all the FrameMaker documents in a directory; or to open
documents in a directory and then print them with custom print settings. You can even
combine applications in a script-for example, to use FrameMaker and a database together(
to produce reports.

FrameMaker comes with several sample AppleScript files. You can use the scripts in these
files with your documents or study them to learn how to write scripts of your own.

For information on writing scripts, see the online manual Using AppleScript with Frame
Products in the Macintosh version of FrameMaker.

Background processing
You can now process FrameMaker tasks while using another application on a Macintosh.
This is especially useful for time-consuming tasks such as updating and generating a large
book file. ~

After you begin the task, bring the other application to the foreground to work in it. The
FrameMaker process will continue as long as necessary in the background.
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You can share documents among any of the platform versions of FrameMaker. A couple of
changes in release 5 make dOlcuments move more easily from one platform to another.

Cross-platform support of documents
(

Vector graphics
FrameMaker uses a new internal format called FrameVectorto ensure that you can display
and print vector graphics across platforms. The FrameVector format renders high-quality
images comparable to native vector graphic formats, and it is supported by all platform
versions of FrameMaker.

(

When you import a vector graphic or open or print a document with an imported vector
graphic, FrameMaker creates a FrameVector facet for the graphic if your platform does not
recognize the graphic's own format. This can happen, for example, if you import a
CorelDraw (CDR) graphic on a Macintosh, or a WordPerfect (WPG) graphic in Windows.
The image you see on your screen or in printed copy is the FrameVector facet.

In earlier releases, FrameMaker created a Framelmage facet for all graphics in a format your
platform does not recognize. Framelmage is a bitmap (raster) format, so it renders an image
of lower quality than a FrameVector image. Now, the Framelmage facet supplements bitmap
graphics, and the FrameVector facet supplements vector graphics.

For more information on FramteVector, Framelmage, and facets, see the online manual
Using Frame Products on Multiple Platforms.

Adobe Type 1 fonts
The UNIX version of FrameMaker now comes with Adobe Type Manager (ATM), a font
rasterizer that converts outline fonts to a bitmap form faron-screen display.

ATM converts Adobe Type 1 outline fonts, which are commonly used in Windows and on
the Macintosh. With ATM, you can open FrameMaker documents from other platforms in
UNIX, and any installed Type 1 fonts in the document will be displayed nicely on your
screen. You can also purchase a wide variety of these fonts available for Windows or
Macintosh, and install and use them for documents you prepare in UNIX. For information
on installing fonts in UNIX, see the online manual Managing Frame Products.

The Windows version of FramteMaker already included ATM.

New and updated filters
FrameMaker comes with an extensive set of filters that convert document and graphic files
from one format to another. RHlease 5 includes several new and updated filters. For more
information on filters, see the online manual Using Frame Filters.
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Document filters
Frame document filters convert documents to other formats so that you can import and (
export them to and from FrameMaker. These are changes to the document filters:

• A new RTF-to-Frame filter converts documents from Rich Text Format (RTF) to the
Frame document format. RTF is an interchange format supported by many word
processing applications. This filter runs automatically when you open an RTF
document.

• The MIF-to-RTF filter has been enhanced for use in developing Windows Help
systems. If any footnotes in the Maker Interchange Format (MIF) document are
numbered with the character +, #, $, K. I, or @, this filter interprets them as special
footnotes for Help topics. It also translates conditional text in MIF to hidden text, which
is used for underlying Help commands.

• The Word-to-MIF filter has been updated to support Word 6.0 and the new features in (
FrameMaker.

• The WordPerfect-to-MIF filter has been updated to support WordPerfect 6.0 and the
new features in FrameMaker.

• The Interleaf-to-MIF filter in the UNIX version has been updated to support Interleaf 5
documents in Interleaf ASCII Format (IAF) 8.0 and the new features in FrameMaker.

Graphics filters
The Frame graphics filters convert graphics to formats that can be displayed and printed in
FrameMaker. These are changes to the graphics filters:

• A new set of FrameVector filters converts vector graphics to the FrameVector format.
FrameVector renders high-quality images comparable to native vector graphics
formats, and it is supported by all platform versions of FrameMaker. These filters are
run automatically when you import, display, or print a vector graphic in a format your
platform does not recognize.

The formats that the filters can convert to FrameVector are Computer Graphics Metafile(
(CGM), Hewlett-Packard Graphics Language (HPGL), Initial Graphics Exchange
Specification (IGES), Windows Metafile Format (WMF), CorelDraw (CDR), Micrographx
Drawing (DRW), AutoCAD Drawing Interchange Format (DXF). 2Soft PC Paintbrush
Bitmap (PCX), Digital Research Graphics Environment Manager (GEM), and WordPerfect
Graphics (WPG).

• A new GIF filter in the UNIX version of FrameMaker supports graphics in the Graphics
Interchange Format (GIF). (The Windows and Macintosh versions already supported
GIF graphics.)

• The Sun Raster filter in the UNIX version now supports 24-bit images as well as 8-bit
images. (The Windows and Macintosh versions already supported 24-bit images.)

• The PCX filter in the UNIX and Macintosh versions now supports 24-bit images as well (
as 8-bit images. (The Windows version already supported 24-bit images.)
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(
Where to go for more information

When you're ready for step-by-step procedures on working with a new feature, turn to one
of the chapters in Using FrameMaker:

(

About this topic

Text frames and text columns

Side heads

Paragraph straddles

Footnote straddles

Table straddles

Anchored frame straddles

Text runarounds

Anchored frame positions

Text imported by reference

Joined lines and curves

Scaling values for imported graphics

Hypertext enhancements

Small Tools palette

QuickAccess bar

Vector graphics

What's New in FrameMaker

See the chapter on

Basic page design, custom page
design, or flow design

Formatting text

Formatting text

Footnotes

Tables

Anchoring graphics

Illustrating a document

Anchoring graphics

Editing text

Illustrating a document

Importing graphics

Hypertext and view-only documents

Illustrating a document

Basic procedures

Importing graphics
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(
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Changes to the FrameMaker
Interface

Release 5 of FrameMaker has many changes in its commands and shortcuts to
accommodate the new features and to make existing features easier to work with. This
chapter provides a quick-reference summary of what has changed in the FrameMaker
interface. For a higher-level oveNiew of the new features, go to Chapter 1.

New and revised in release 5

In this chapter
(

Menu commands:

"File menu" on page 22

"Edit menu" on page 23

"Format menu" on page 24

"View menu" on page 26

"Special menu" on page 27

"Graphics menu" on page 27

"Table menu" on page 29

"Help menu" on page 29

"Book menus" on page 29

(

(

Keyboard and mouse shortcuts:

"Designing pages" on page 30

"Editing and formatting documents" on page 31

"Drawing and editing graphics" on page 31

"Working with text insets and publishers" on page 31

Changes from release 4
If you have worked with an earlier release of FrameMaker, you may find that a familiar menu
command is not in its old location or that a keyboard shortcut no longer works. These topics
review how the interface has changed from release 4:

"Reorganized commands" on page 32

"Renamed commands" on page 33

"Deleted commands" on page 33

"Deleted shortcuts" on page 34
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New and revised menu commands

FrameMaker has several new menu commands that you'll use to work with features suc~
as text frames, text runarounds, and joined objects. Many of the existing commands have
also been improved. This section summarizes these changes by menu.

Some commands have been reorganized on the menus so that their location and grouping
are more intuitive. In particular, the page layout and document format commands are
organized differently now. A few commands have been removed from this release of
FrameMaker, but their functionality is still available in other new or revised commands.

File menu

Command

New, Open, Save As,
and Import File
(Windows)

Import File (text)

Import File (graphics)

Import File (graphics)
(UNIX and Windows)

Import Filename

What's new or changed

Changed: These dialog boxes now have a Network button in (
Windows. If you're running Windows for Workgroups release 3.11,
you can click this button to open a dialog box for connecting to other
hard drives or partitions available on your network.

Changed: You can now use the Import File command to import text
by reference to the source. The text you import can be from another
FrameMaker document, a text file, or a filtered document.

Text imported by reference is called a text inset. You can update the
inset, either automatically or manually, so that it matches current
text in the source.

After you select a file to import and a method of importing, an Import
Text by Reference dialog box appears. You use this dialog box to
supply more information. The exact name of the dialog box and the
options in it vary with the type of file you're importing.

When importing text from a FrameMaker document with Import File,
either by reference or by copying, you can now specify which flow
to import and how to format the text. You can retain the text's format (
from the source, reformat the text to use catalogs in your document,
or reformat it using the paragraph format at the insertion point.

Changed: If you select text in a document before choosing Import
File, the imported graphic replaces the text selection. (In earlier
releases of FrameMaker, the graphic appeared at the beginning of
the selection and did not replace it.)

Changed: After you select a graphic file to import, if FrameMaker
cannot determine the format of the graphic, the Unknown File Type
dialog box appears so that you can select a format.

New: The bottom of the Import submenu shows the names of up to
five open files in Normal format or Interchange format (MIF). If you (
choose one of these filenames, the Import Text Flow by Reference
dialog box appears so that you can import the file without using the
Import File command.
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(

(

Command

Print

Preferences
(Macintosh)

Filenames
(UNIX)

Edit menu

What"s new or changed

Changed: The Print dialog box now has options for exporting a
document to Adobe Acrobat. You can turn on the option "Generate
Acrobat Data" to set the printing values appropriately for Acrobat.

If you click the Adobe Setup button, another dialog box appears.
You use this dialog box to select which paragraph tags become
bookmarks and to specify an outline level for each bookmark. In
Acrobat, the bookmarks form an outline that readers can click to go
to sections in an online document.

You can now also print the files in a book as individual PostScript
files rather than as one PostScript file. When specifying the location
of the output, type an asterisk (*) in place of a specific filename. (In
UNIX and Windows, the asterisk is the last item in the pathname.)

Changed: You can now have FrameMaker create and save a
Framelmage facet for graphics you import by copy. You turn on the
option "Save Framelmage with Imported Graphics." Facets are
used for displaying or printing graphics on other platforms.

This option was already available in the Windows version. In UNIX,
facets are saved automatically for all graphics imported by copy.

New: Near the bottom of the File menu are the names of the last five
files you opened or saved with the Save As command. You can
ChOOSl3 one of these filenames to reopen the file.

This fE!ature was already available in the Windows and Macintosh
versions.

Command

Find Next
(UNIX)(

(

What's new or changed

New: This command repeats the find request you last specified in
the Find/Change dialog box. The dialog box does not have to be
open for you to use Find Next.

This fE!ature was already available in the Windows and Macintosh
versions.

Text Inset Properties New: This command shows the source of the selected inset, the
method of updating (automatic or manual), and the date and time
the inset was last modified and updated.

You can also use this command to update the inset, convert the
inset to text, open the source document, and change options such
as the method of updating.
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Command

Update References

What's new or changed

New: This command updates cross-references and text insets in (
the current document. You can specify whether to update insets
marked for manual updating or automatic updating or both.

You can also use this command to suppress automatic updating of
insets and cross-references and to update unresolved cross­
references.

Format menu
The page layout and document formatting commands are organized on three new
submenus in the Format menu: Page Layout, Customize Layout, and Document. The Pages
submenu from release 4, its Layout palette, and some of the Layout palette commands have
been removed. The sections that follow this one describe the new submenus. (

The commands Page Break, Flow, Document, Change Bars, and Footnote Properties are
no longer on the Format menu. Some of these have been moved to the new submenus,
and others have been deleted.

Command

Character Designer
(Macintosh)

Paragraph
Designer: Basic

Paragraph
Designer: Default
Font (Macintosh)

Paragraph
Designer: Pagination

What's new or changed

Changed: The Color pop-up menu for a character format on a
Macintosh now shows swatches of color next to the color names.

Changed: The Tab Stops scroll list has a new checkbox with three
states: on, off, and as is.

When more than one paragraph is selected, you can turn on the
checkbox to apply the tab stops to all of the selected paragraphs,
turn off the checkbox to remove the tab stops from the paragraphs,
or set the checkbox to "as is" to leave the tab stops as they are.

Changed: The Color pop-up menu for a paragraph format on a
Macintosh now shows swatches of color next to the color names.

Changed: You can now make any paragraph or footnote straddle all (
of the columns in its text frame or all of the columns plus the side­
head area.

You no longer specify leaving room for side heads in a paragraph's
Pagin,alion properties. The side-head area is now part of the text
frame properties set with the Column Layout and Customize Text
Frame commands.

(
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(
Format menu: Page Layout submenu
The new Page Layout submenu groups the most commonly used commands for laying out
pages. The only changes in fUinctionality are to accommodate the new text frame and its
side-head area.

The commands Master Page Usage, New Master Page, and Update Column Layout
(formerly called Update Page layouts) have been moved to this submenu from the old
Layout palette.

(

Command

Column Layout

Line Layout

Page Size

What's new or changed

New: This command combines all the features you need to layout
a basic page. The settings apply to all text frames in the main text
flow. (This command replaces Normal Page Layout.)

You can specify the number of columns in the layout and the gap
betweE~n them; the size of the margins; and the width, gap, and
location of the side-head area.

This command also updates body pages and master pages with
any changes you make.

New:This command changes synchronization and feather settings
for a te~xt flow. (These settings were formerly in the Flow Properties
dialog box.)

New: This command changes the page size and the single- or
double-sided setting of an existing document. (These settings were
formerly in the Normal Page Layout dialog box.)

Format menu: Customi2:e Layout submenu
The new Customize Layout submenu incorporates commands for modifying an individual
text frame or page. The commands Disconnect Previous, Disconnect Next, Disconnect Both,
Rotate Page Clockwise, RotatE~ Page Counterclockwise, and Unrotate Page have been
moved to this submenu from the old Layout palette.

(

Command

Customize Text
Frame

What's New in FrameMaker

What's new or changed

New: This command puts all the properties of a single text frame in
one convenient place. The settings apply to the current text frame.
(You can select a frame and then choose Object Properties from
the Graphics menu to open the same dialog box.)

You can change the size of a text frame; the number of columns and
the gap between them; the width, gap, and location of the side-head
area; tile color, angle, and border width of the frame; the flow tag;
and thl~ Autoconnect and PostScript Code settings.

Most changes you make with Customize Text Frame apply only to
one teJ<t frame and not to an entire flow. Only Autoconnect, the flow
tag, and the checkbox for side heads apply to the flow.
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Command

Connect Text Frames

Split Text Frame

What's new or changed

New: This command connects the last column in one text frame to (
the first column in another text frame so that the text flows through
the frames. You select the text frames to connect before choosing
the command. (This command replaces Connect Columns.)

New: This command splits a text frame into two disconnected
frames below the insertion point. (This command replaces Split
Column.)

Format menu: Document submenu
The new Document submenu groups formatting commands that apply across an entire
document. The Change Bars and Footnote Properties commands have been moved to this
submenu from the Format menu. (

Command What's new or changed

Numbering New: This command sets the first page number, the numbering
style, and the even/odd page count for a document. (These settings
were formerly in the Document Properties dialog box.)

Text Options New: This command sets text properties such as Smart Quotes,
Smart Spaces, line breaks, and small-cap sizes for a document.
(These settings were formerly in the Document Properties
dialog box.)

View menu

Command

QuickAccess Bar
(UNIX)

QuickAccess Bar

Publisher
Boundaries
(Macintosh)

Color Definitions
(UNIX)

What's new or changed

New: You can choose this command to display a QuickAccess bar
in UNIX. The bar shows buttons for many of the most commonly
used commands for working with files, text, graphics. and
tables.You click a button to use its command.

The QuickAccess bar was already available in the Windows and
Macintosh versions.

Changed: The buttons in the QuickAccess bar are now in color on
a color monitor or in grays on a gray-scale monitor.

New: This command shows or hides brackets around publishers in
a document. Each publisher has an opening bracket ( [ ) and a
closing bracket ( ] ). The brackets are printable characters.

Changed: You now use this command to select a color model as
well as to define colors in UNIX. The separate Color Model
command has been removed.

The Color Definitions dialog box already included color models in
the Windows and Macintosh versions.
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(
Special menu
The Page Break command has been moved to the Special menu from the Format menu,
and the Inset command in the UNIX version is now called Graphic Inset.

(

(

(

Command

Anchored Frame

Cross-Reference

Marker
(UNIX and Windows)

Graphics menu

Command

Tools

What's New in FrameMaker

What"s new or changed

Changed: The Anchored Frame dialog box now lists all of the
anchoring positions on a pop-up menu. When you select a position,
the rest of the dialog box shows only the settings (such as size and
alignment) that are appropriate for that position.

You can now position an anchored frame outside a text frame as
well as outside a text column. In a document with two or more
columns, positioning an anchored frame outside the text frame
ensurElS that the anchored frame is always in the page margin.

You can also create a run-in frame aligned on the left or right side
of a paragraph. The text in the paragraph runs around the frame.

With any of the anchoring positions, you can align an anchored
frame with the page side closer to or farther from the binding in a
doubIE!-sided document.

Baseline Offset is now called Distance above Baseline. Near-Side
Offset is now called Distance from Text Column (or Text Frame).

Changed: The Cross-Reference dialog box has been reorganized
to group related tasks. The top of the dialog box combines source
information with the Go to Source button; the middle combines the
format with the Edit Format button; and the bottom shows the
remaining buttons.

The Update feature has been moved to Update References in the
Edit menu.

Changed: The Marker Text box can now show several lines of text
at a time rather than only one line in UNIX and Windows. This
makes it easier to edit long passages of marker text.

The Marker Text box in the Macintosh version already displayed
several lines of text.

What"s new or changed

Changed: The button for the Text Column tool now chooses the
Text Frame tool. You click this tool and drag to draw a text frame. A
dialog box appears automatically so that you can specify the
number of columns in the frame and the gap between them.

The button for the Graphic Frame tool now shows an icon of graphic
objects in a frame rather than the word Frame.
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Command

Tools
(UNIX)

Tools
(Macintosh)

Join

Object Properties
(Macintosh)

Object Properties:
Text Frame

Object Properties:
Imported Graphic
(UNIX and Windows)

What's new or changed

Changed: The Tools palette in UNIX is now available in an (
abbreviated size as well as in its full size. The small palette takes
up much less space on your screen.

The small Tools palette has all of the drawing tools and the same
object properties (such as fill pattern and pen width) that the large
palette has; the properties are on pop-up menus. The small palette
does not have the Graphics menu commands.

You can go back and forth between the small and large Tools
palettes by clicking a toggle switch at the bottom of the palette.

The small Tools palette was already available in the Windows and
Macintosh versions. The Macintosh version also has a large
p~ette. (

Changed: The Color pop-up menu on the large and small Tools
palettes in the Macintosh version now shows swatches of color next
to the color names.

New: This command joins selected lines and curves into one
complex outline. Once you've created this object, you can reshape
it and change its fill color and other properties.

You can join any lines, polylines, arcs, and smoothed polylines
drawn with FrameMaker drawing tools.

Changed: The Color pop-up menu in the Object Properties dialog
box on a Macintosh now shows swatches of color next to the color
names.

New: This command puts all the properties of a single text frame in
one convenient place. You select a text frame to modify before
choosing the command. (You can choose Customize Text Frame
from the Format>Customize Layout submenu to open the same
dialog box.)

You can change the size of a text frame; the number of columns and (
the gap between them; the width, gap, and location of the side-head
area; the color, angle, and border width of the frame; the flow tag;
and the Autoconnect and PostScript Code settings.

Most changes you make to a text frame with Object Properties
apply only to one frame and not to an entire flow. Only Autoconnect,
the flow tag, and the checkbox for side heads apply to the flow.

Changed: You can now change the dots-per-inch (dpi) value for an
imported bitmap graphic with Object Properties in UNIX and
Windows. (In earlier releases of FrameMaker, you had to reimport
a graphic to change its dpi value.)

This feature was already available in the Macintosh version.
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(

(

Command

Runaround
Properties

Table menu

Command

Insert Table
and
Convert to Table

Help menu

Command

Tutorial

What's new or changed

New: This command makes text in a column run around a selected
graphic. The graphic must be attached to a fixed location on the
page. The border of the text can follow the contours of the graphic
or a rectangular boundary around the graphic.

What's new or changed

Changed: The Insert Table and Convert to Table dialog boxes no
longer have a Table Tag text box. You can select a format in the
Table Format list to specify a format for a new table.

In both Insert Table and Convert to Table, FrameMaker creates a
table with a default format if the Table Format list is empty. You can
then use the Table Designer to name and modify the table's format
and to sav'e the format in the catalog.

What's new or changed

New: This online tutorial guides you through the fundamentals of
FrameMaker. You work with sample documents and eight
interactive lessons to learn basic FrameMaker tasks-including
laying out pages, formatting paragraphs, importing graphics. and
generating a table of contents.

(

Book menus
The book menu bar for all the versions of FrameMaker now includes an Edit menu. In the
UNIX version, a few existing File menu commands have been organized on Import and
Utilities submenus to be consistent with Windows and Macintosh FrameMaker.

Command

Add File
(File menu for books)

Suppress Automatic
Reference Updating
(Edit menu for books)

What's New in FrameMaker

What's new or changed

Changed: The Add File to Book dialog box now stays open on the
screen while you add files to a book. This makes it much easier to
add more than one file at a time. When you're finished adding files.
you click Done to close the dialog box.

New: If a document has cross-references and any text insets that
are updated automatically. FrameMaker updates the cross­
references and insets whenever you open the document. You can
use this command to turn off the updating for all documents you
open from the book window.
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New and revised keyboard and mouse shortcuts
FrameMaker provides keyboard shortcuts for all menu commands and for many of the (
specific settings you can make. It also gives you mouse shortcuts that combine commands
with easy on-screen manipulation. This section describes the keyboard and mouse
shortcuts that are new or that now perform a different function.

To use the keyboard shortcuts in this section, press the keys in succession. For example,
for Esc e F, press the Escape key, then lowercase e, and then uppercase F.

Some of the new keyboard shortcuts have an additional Control-key equivalent in Windows
or Command-key equivalent on the Macintosh. For shortcuts using the Control key or
Command key, see the Quick Reference for Windows or Macintosh FrameMaker.

Occasionally, a new keyboard shortcut replaces another one because the letters in the
replacement correspond to a new location or new name for the associated command. In (
these cases, you can still use the old shortcut.

Designing pages

To

Open the Column Layout dialog box (old shortcut
opened the Normal Page Layout dialog box)

Open the Line Layout dialog box

Open the Page Size dialog box

Open the Master Page Usage dialog box

Open the New Master Page dialog box

Open the Update Column Layout dialog box

Open the Customize Text Frame dialog box

Turn room for side heads on or off

Connect selected text frames (formerly connected
selected text columns)

Disconnect the previous text frame (formerly
disconnected the previous text column)

Disconnect the next text frame (formerly
disconnected the next text column)

Disconnect the previous and next text frames
(formerly disconnected the previous and next text
columns)

Split the current text frame below the selection
(formerly split the current text column)

Choose the Text Frame tool (old shortcut chose the
Text Column tool)

Changes to the FrameMaker Interface

Press

Esc 0 c I
(lowercase L)

Esc 0 II
(lowercase L)

Esc 0 P s

Esc 0 m u

Esc 0 m p

Esc 0 u P

Esc 0 c f

Esc j P S

Esc C C

EscC P

EscC N

EscC B

EscC S

Esc 1 (one) t f

Replaces

Esc 0 g n

Esc 0 g m

Escp m

Esc p u

Esc 1 (one) t c

(
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Editing and formatting documents

( To Press Replaces

Repeat the last find request Esc e F

Make the current paragraph straddle all columns in its Esc j P t
text frame, not including the side-head area (formerly
made the paragraph "full width")

Make the current paragraph straddle all columns and Esc j p T
the side-head area in its text frame

Open the Numbering Options dialog box Esc 0 d n

Open the Text Options dialog box Esc 0 t 0

Show the QuickAccess bar (show or hide the bar in Esc v q

( the Windows version)

Insert a page break Esc s p b Esc 0 P b

Drawing and editing graphics

To Press Replaces

Insert a graphic inset (UNIX) Esc s g Esc s i

Open the Runaround Properties dialog box Esc g R

Run text around the contour of a selected graphic Escg w

Run text around the bounding box of a selected Escg W
graphic

Turn off a text runaround for a selected graphic Esc g q

Join selected open curves into one complex outline Esc g j

Working with text insets and publishers
( To Press

Open the Text Inset Properties dialog box for a Esc e i
selected text inset

Open the Update References dialog box Esc e U

Open the Suppress Automatic Reference Updating Esc e S
dialog box (when a book file is active)

Interrupt the updating of text insets Control-c

Show or hide brackets around Macintosh publishers Esc v I (lowercase L)

To Do this with the mouse

( Select a text inset and open thE! Text Inset Properties Double-click the inset
dialog box for it
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Changes to older commands and shortcuts

This section summarizes the FrameMaker 4 commands that have been moved or renamed(
and the commands and shortcuts that have been deleted.

Reorganized commands
Some of the existing commands have been reorganized on the menus so that their location
and grouping are more intuitive. These commands work the same way they did in earlier
releases of FrameMaker.

Command Old location New location

Page Break Format menu Special menu

Change Bars Format menu Format>Document submenu
(Footnote Properties Format menu Format>Document submenu

Master Page Usage Format>Pages submenu Format>Page Layout
and Layout palette submenu

New Master Page Layout palette Format>Page Layout
submenu

Update Page Layouts Layout palette Format>Page Layout
(now called Update submenu
Column Layout)

Disconnect Previous Layout palette Format>Customize Layout
submenu

Disconnect Next Layout palette Format>Customize Layout
submenu

Disconnect Both Layout palette Format>Customize Layout
submenu

Rotate Page Clockwise Layout palette Format>Customize Layout
submenu (

Rotate Page Layout palette Format>Customize Layout
Counterclockwise submenu

Unrotate Page Layout palette Format>Customize Layout
submenu

Compare Books File menu for books File>Utilities submenu for
(UNIX) books

Keyboard Macros File menu for books File>Utilities submenu for
(UNIX) books

Import Formats File menu for books File>lmport submenu for
(UNIX) books
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(
Renamed commands
A couple of commands have been renamed to clarify their role in the application. These
commands work the same way they did in earlier releases.

Command

Update Page Layouts (Layout
palette)

Inset (Special menu)
(UNIX)

New name

Update Column Layout (moved to
Format>Page Layout submenu)

Graphic Inset

(

Deleted commands
A few commands have been nemoved from this release of FrameMaker, but their
functionality is still available, in new or revised commands.

(

Command

Flow (Format menu)

Document (Format menu)

Normal Page Layout (Layout
palette and Format>Pages
submenu)

Connect Columns (Layout
palette)

Replace Columns (Layout
palette)

Split Current Column (Layout
palette)

Color Model (View menu)
(UNIX)

What's New in FrameMaker

Functionality replaced by

Line Layout (Format>Page Layout submenu),
Customize Text Frame (Format>Customize Layout
submenu), and Object Properties: Text Frame
(Graphics menu)

Numbering (Format>Document submenu) and Text
Options (Format>Document submenu)

Column Layout (Format>Page Layout submenu) and
Page Size (Format>Page Layout submenu)

Connect Text Frames (Format>Customize Layout
submenu)

Customize Text Frame (Format>Customize Layout
submenu) and Object Properties: Text Frame
(Graphics menu)

Split Text Frame (Format>Customize Layout
submenu)

Color Definitions (View menu)
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Deleted shortcuts
Some of the keyboard shortcuts have been removed altogether. The commands associate
with these shortcuts no longer exist in FrameMaker, because their functionality is available
in other commands or because you no longer work with individual text columns.

Shortcut

Esc 0 I

Esc 0 d

Esc 0 g I

Esc C r

EscC R

Esc C L

Esc v c m

Changes to the FrameMaker Interface

Purpose

Opened the Flow Properties dialog box

Opened the Document Properties dialog box

Displayed the Layout palette

Opened the Replace Columns dialog box

Split the current column to the right of the selection

Split the current column into lines

Opened the Color Model dialog box (UNIX) (

(

(
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